TYPO3 v6.2.49, 7.6.42 and 8.7.33 ELTS Released

Our TYPO3 ELTS Team released a new version for TYPO3 v6.2.49, 7.6.42, and 8.7.33. As always with our ELTS security releases, the main focus is to keep the instance stable and the backend running smoothly, regardless of browsers changing their behaviour in the course of time.

Are you still running your website on an end-of-life version of TYPO3?

TYPO3 CMS always has two current versions supplied with free security and bug fixing (currently TYPO3 version 9.5 and version 10.4).

TYPO3 8.7 was officially marked as unsupported by the Core Team on March 31, 2020, TYPO3 7.6 was officially marked as unsupported by the Core Team on December 11, 2018, while TYPO3 6.2 was officially marked unsupported by the Core Team on March 31, 2017 when TYPO3 version 8.7 was released. Sometimes there are good reasons for sticking to an older version, and that doesn’t have to be a problem.

However, one thing has to be a top priority at all times, and that’s staying on top of maintenance and security updates.

Maybe your website is still delivering everything you need. Or maybe the update of your website is just taking longer than expected. Gain peace of mind through opting for one of TYPO3 GmbH’s ELTS plans. 

Learn more about TYPO3 GmbH Extended Long Term Support

Comments

Great, thanks for sharing this blog.Really looking forward to read more. Keep writing

Hi, where should ELTS 8 issues be reported?

Please have a look at this core issue:

https://forge.typo3.org/issues/91404

We encounter this problems now with ELTS 8.7.33 and 8.7.34

@Snipi - Please report any issues you encounter with ELTS 7.6 here https://jira.typo3.com/servicedesk/customer/portal/11 - ideally including a Stack Trace and steps to reproduce so we can help you.

can i get some hint how to avoid #1588784141: Cannot serialize TYPO3\CMS\Core\Log\Writer\AbstractWriter ... on v. 7.6.42 ? each time when typo3 FE will serialize their own classes, got this and stuck in nowhere...

Write comment

* These fields are required